CVE-2026-54264
Fixed upstream EPSS <1%CVSS 8.3
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, an information disclosure vulnerability exists in the @angular/service-worker package of the Angular framework. When the Service Worker fetches assets, it preserves metadata (such as headers) from the original request. However, on cross-origin redirects, the Service Worker fails to strip sensitive headers, violating the Fetch redirect algorithm. This allows a remote attacker to obtain sensitive credentials (e.g., Authorization tokens, Proxy-Authorization credentials, or session cookies) by triggering a cross-origin redirect to an untrusted external origin. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.
Products: angular
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | @angular/service-worker | 22.0.1 |
| npm | @angular/service-worker | 21.2.17 |
| npm | @angular/service-worker | 20.3.25 |
| npm | @angular/service-worker | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | angular.js | no fix |
| Debian 13 | angular.js | no fix |
| Ubuntu 22.04 LTS | angular.js | no fix |
| Ubuntu 24.04 LTS | angular.js | no fix |
| Ubuntu 25.10 | angular.js | no fix |
| Ubuntu 26.04 LTS | angular.js | no fix |
| Ubuntu 26.10 | angular.js | no fix |
| Ubuntu Pro 16.04 LTS | angular.js | no fix |
| Ubuntu Pro 18.04 LTS | angular.js | no fix |
| Ubuntu Pro 20.04 LTS | angular.js | no fix |