CVE-2026-53622
Fixed in a distro release EPSS <1%CVSS 7.8
Traefik is an HTTP reverse proxy and load balancer. Versions prior to 3.7.3, 3.6.18, and 2.11.51 have a critical vulnerability in Traefik's HTTP/3 (QUIC) TLS configuration selection that allows unauthenticated clients to bypass router-specific mTLS enforcement. When HTTP/3 is enabled on an entrypoint, the TLS handshake selects the applicable TLS configuration through an exact, case-sensitive lookup on the SNI value, which fails to match wildcard host patterns (e.g., *.example.com) or case variants of the configured hostname. Because the handshake falls back to the default TLS configuration — which may not require client certificates — a client can complete the QUIC handshake without presenting a certificate, while the subsequent HTTP routing layer still dispatches the request to a backend protected by a router-specific mTLS policy. The issue affects deployments where HTTP/3 is enabled, a router uses a wildcard Host rule or case-insensitive hostname matching, a router-specific TLSOptions enforces client certificate authentication, and UDP access to the entrypoint is reachable by an attacker. This vulnerability is fixed in versions 3.7.3, 3.6.18, and 2.11.51.
Products: traefik, Red Hat OpenShift Dev Spaces 3.30
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/traefik/traefik | no fix |
| Go | github.com/traefik/traefik/v2 | 2.11.51 |
| Go | github.com/traefik/traefik/v3 | 3.7.3 |
| Go | github.com/traefik/traefik/v3 | 3.6.18 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | traefik-2.11 | 2.11.57-r3 |
| Chainguard | traefik-2.11 | 2.11.51-r0 |
| Chainguard | traefik-3.6 | 0 |
| Chainguard | traefik-fips-2.11 | 2.11.51-r0 |
| Chainguard | traefik-fips-3.6 | 0 |
| SUSE Linux Enterprise Server 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| Wolfi | traefik-3.6 | 0 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| openSUSE Tumbleweed | traefik | 3.7.5-1.1 |