CVE-2026-53441
Fixed in a distro release EPSS <1%CVSS 5.4
Jenkins 2.483 through 2.567 (both inclusive), LTS 2.492.1 through 2.555.2 (both inclusive) does not escape the user-provided description of a generic offline cause that could be set through the `POST config.xml` API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.
Products: Jenkins project Jenkins
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.jenkins-ci.main:jenkins-core | 2.568 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | jenkins-2.528 | no fix |
| Chainguard | jenkins-2.528-openjdk-17 | no fix |
| Chainguard | jenkins-2.528-openjdk-21 | no fix |
| Chainguard | jenkins-2.541 | no fix |
| Chainguard | jenkins-2.541-openjdk-17 | no fix |
| Chainguard | jenkins-2.541-openjdk-21 | no fix |
| Chainguard | jenkins-2.541-openjdk-25 | no fix |
| Chainguard | jenkins-2.555-openjdk-21 | 2.555.3-r0 |
| Chainguard | jenkins-2.555-openjdk-25 | 2.555.3-r0 |