CVE-2026-52845
Fixed in a distro release EPSS <1%CVSS 8.1
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.
Products: caddyserver caddy, Red Hat Hardened Images
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/caddyserver/caddy | no fix |
| Go | github.com/caddyserver/caddy/v2 | 2.11.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian:12 | caddy | 2.6.2-5+deb12u1 |
| Debian:13 | caddy | 2.6.2-12+deb13u1 |
| Debian:14 | caddy | 2.11.4-1 |
| SUSE:Linux Enterprise Server 16.0 | govulncheck-vulndb | 0.0.20260727T201416-160000.1.1 |
| SUSE:Linux Enterprise Server for SAP applications 16.0 | govulncheck-vulndb | 0.0.20260727T201416-160000.1.1 |
| Ubuntu:25.10 | caddy | no fix |
| Ubuntu:26.10 | caddy | no fix |
| Ubuntu:Pro:24.04:LTS | caddy | no fix |
| Ubuntu:Pro:26.04:LTS | caddy | no fix |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260727T201416-160000.1.1 |