CVE-2026-52760
No fix known EPSS <1%CVSS 6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web Console. The browse page in the web console renders a message Id directly without sanitization. This allows an authenticated producer to send a message with a JMS message ID that has been crafted to contain HTML/JavaScript such that when an administrator browses the queue in the Web Console, the payload executes in their browser. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Web Console: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ Web Console
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | activemq | no fix |
| Debian 13 | activemq | no fix |
| Ubuntu 24.04 LTS | activemq | no fix |
| Ubuntu 25.10 | activemq | no fix |
| Ubuntu 26.04 LTS | activemq | no fix |
| Ubuntu 26.10 | activemq | no fix |
| Ubuntu Pro 16.04 LTS | activemq | no fix |
| Ubuntu Pro 18.04 LTS | activemq | no fix |
| Ubuntu Pro 20.04 LTS | activemq | no fix |
| Ubuntu Pro 22.04 LTS | activemq | no fix |