CVE-2026-50750
No fix known EPSS <1%CVSS 7.5
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Following the fix for CVE-2026-49270 an unauthenticated attacker can now cause broker OOM by sending an repeated BrokerInfo commands without sending a ConnectionInfo, until the broker will crash with OOM. This issue affects Apache ActiveMQ Broker: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7; Apache ActiveMQ All: from 5.19.7 before 5.19.8, from 6.2.6 before 6.2.7. Users are recommended to upgrade to version 6.2.7, which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ Broker, Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ All
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | activemq | no fix |
| Debian 13 | activemq | no fix |
| Ubuntu 24.04 LTS | activemq | no fix |
| Ubuntu 25.10 | activemq | no fix |
| Ubuntu 26.04 LTS | activemq | no fix |
| Ubuntu 26.10 | activemq | no fix |
| Ubuntu Pro 16.04 LTS | activemq | no fix |
| Ubuntu Pro 18.04 LTS | activemq | no fix |
| Ubuntu Pro 20.04 LTS | activemq | no fix |
| Ubuntu Pro 22.04 LTS | activemq | no fix |