CVE-2026-49762
Fixed in a distro release EPSS <1%CVSS 5.1
Uncontrolled Resource Consumption vulnerability in the Elixir standard library's Version module allows an attacker who controls a version string to cause a denial of service through CPU and memory exhaustion. The version parser converts numeric version components (major, minor, patch and numeric pre-release/build identifiers) to integers without bounding their length. A single large all-digit component therefore forces a super-linear, non-yielding base-10 to arbitrary-precision integer conversion (String.to_integer/1, i.e. :erlang.binary_to_integer/1) that pins a BEAM scheduler, and a larger component raises an uncaught SystemLimitError that crashes the calling process. A single moderately sized string (around one megabyte) is enough; no authentication is required. This is reachable from the public entry points Version.parse/1, Version.parse!/1, Version.match?/3, Version.compare/2, and Version.parse_requirement/1, which applications routinely call on untrusted input such as HTTP parameters, dependency-manifest fields, and package metadata. This vulnerability is associated with program files lib/version.ex and program routines 'Elixir.Version.Parser':parse_digits/2. This issue affects elixir: from 0.9.3 before 1.20.1.
Products: elixir-lang elixir
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | elixir-lang | no fix |
| Debian 13 | elixir-lang | no fix |
| Debian 14 | elixir-lang | 1.20.1.dfsg-1 |
| Ubuntu 16.04 LTS | elixir-lang | no fix |
| Ubuntu 18.04 LTS | elixir-lang | no fix |
| Ubuntu 20.04 LTS | elixir-lang | no fix |
| Ubuntu 22.04 LTS | elixir-lang | no fix |
| Ubuntu 24.04 LTS | elixir-lang | no fix |
| Ubuntu 25.10 | elixir-lang | no fix |
| Ubuntu 26.04 LTS | elixir-lang | no fix |
| Ubuntu 26.10 | elixir-lang | no fix |