CVE-2026-49432
No fix known EPSS <1%CVSS 7.5
Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ All, Apache Software Foundation Apache ActiveMQ Stomp
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | activemq | no fix |
| Debian 13 | activemq | no fix |
| Ubuntu 24.04 LTS | activemq | no fix |
| Ubuntu 25.10 | activemq | no fix |
| Ubuntu 26.04 LTS | activemq | no fix |
| Ubuntu 26.10 | activemq | no fix |
| Ubuntu Pro 16.04 LTS | activemq | no fix |
| Ubuntu Pro 18.04 LTS | activemq | no fix |
| Ubuntu Pro 20.04 LTS | activemq | no fix |
| Ubuntu Pro 22.04 LTS | activemq | no fix |