CVE-2026-4915
Fixed in a distro release EPSS <1%CVSS 6.5
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to filter nil elements from outgoing webhook attachment payloads before processing, which allows an authenticated user to cause a denial of service (server process termination) via a crafted webhook callback response containing a null attachment entry.. Mattermost Advisory ID: MMSA-2026-00641
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.6.1 |
| Go | github.com/mattermost/mattermost-server | 11.5.4 |
| Go | github.com/mattermost/mattermost-server | 11.4.5 |
| Go | github.com/mattermost/mattermost-server | 10.11.15 |
| Go | github.com/mattermost/mattermost-server | 10.11.15+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.5+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.6.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260407102538-faa7d75b4ea0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |