CVE-2026-49042
Fixed upstream EPSS <1%CVSS 7.3
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
Products: Apache Software Foundation Apache Camel
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.camel:camel-langchain4j-agent | 4.18.3 |
| Maven | org.apache.camel:camel-langchain4j-agent | 4.21.0 |
| Maven | org.apache.camel:camel-langchain4j-tools | 4.18.3 |
| Maven | org.apache.camel:camel-langchain4j-tools | 4.21.0 |
| Maven | org.apache.camel:camel-spring-ai-tools | 4.18.3 |
| Maven | org.apache.camel:camel-spring-ai-tools | 4.21.0 |