CVE-2026-48748
Fixed in a distro release EPSS <1%CVSS 7.5
Netty is a network application framework for development of protocol servers and clients. Starting in version 4.2.0.Final and prior to version 4.2.15.Final, a memory exhaustion vulnerability in the Netty HTTP/3 codec allows the creation of an infinite number of blocked streams, which can cause OOM error. Version 4.2.15.Final patches the issue.
Products: netty, Red Hat build of Apache Camel - HawtIO 4
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | io.netty:netty-codec-http3 | 4.2.15.Final |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-hop | 2.18.0-r6 |
| Chainguard | celeborn-0.7 | 0.7.0-r2 |
| Chainguard | spark-4.1-scala-2.13 | 4.1.2-r4 |
| Debian 12 | netty | no fix |
| Debian 13 | netty | no fix |
| Debian 14 | netty | no fix |
| Ubuntu 25.10 | netty | no fix |
| Ubuntu 26.10 | netty | no fix |
| Ubuntu Pro 14.04 LTS | netty | no fix |
| Ubuntu Pro 16.04 LTS | netty | no fix |
| Ubuntu Pro 18.04 LTS | netty | no fix |
| Ubuntu Pro 20.04 LTS | netty | no fix |
| Ubuntu Pro 22.04 LTS | netty | no fix |
| Ubuntu Pro 24.04 LTS | netty | no fix |
| Ubuntu Pro 26.04 LTS | netty | no fix |
| Wolfi | spark-4.1-scala-2.13 | 4.1.2-r4 |