CVE-2026-48586
Fixed in a distro release EPSS 1%CVSS 8.7
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Products: Apache Software Foundation Apache Thrift
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | thrift | no fix |
| Debian 13 | thrift | no fix |
| Debian 14 | thrift | no fix |
| Red Hat hummingbird 1 | jaeger | 0:2.20.0-0.4.hum1 |
| Red Hat hummingbird 1 | jaeger | 0:2.20.0-0.5.hum1 |
| Red Hat hummingbird 1 | loki3.7 | 0:3.7.4-0.1.hum1 |
| Red Hat hummingbird 1 | loki3.7-canary | 0:3.7.4-0.1.hum1 |
| Red Hat hummingbird 1 | loki3.7-logcli | 0:3.7.4-0.1.hum1 |
| Red Hat hummingbird 1 | opentelemetry-collector | 0:0.157.0-0.1.hum1 |
| Red Hat hummingbird 1 | opentelemetry-collector-contrib | 0:0.157.0-0.1.hum1 |
| Red Hat hummingbird 1 | tempo2.10 | 0:2.10.7-0.2.hum1 |
| Red Hat hummingbird 1 | tempo3.0 | 0:3.0.2-0.2.hum1 |
| Ubuntu 16.04 LTS | libthrift-java | no fix |
| Ubuntu 18.04 LTS | libthrift-java | no fix |
| Ubuntu 20.04 LTS | thrift | no fix |
| Ubuntu 22.04 LTS | libthrift-java | no fix |
| Ubuntu 22.04 LTS | thrift | no fix |
| Ubuntu 24.04 LTS | libthrift-java | no fix |
| Ubuntu 24.04 LTS | thrift | no fix |
| Ubuntu 26.04 LTS | libthrift-java | no fix |
| Ubuntu 26.04 LTS | thrift | no fix |
| Ubuntu 26.10 | libthrift-java | no fix |
| Ubuntu 26.10 | thrift | no fix |
| openSUSE Tumbleweed | thrift | 0.24.0-1.1 |