CVE-2026-4858
Fixed in a distro release EPSS <1%CVSS 8.0
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to check integration URL for path traversal which allows an malicious authenticated user to call an arbitrary API via system admin Mattermost auth token using via path traversal in integration action URL.. Mattermost Advisory ID: MMSA-2026-00640
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.6.1 |
| Go | github.com/mattermost/mattermost-server | 11.5.4 |
| Go | github.com/mattermost/mattermost-server | 11.4.5 |
| Go | github.com/mattermost/mattermost-server | 10.11.15 |
| Go | github.com/mattermost/mattermost-server | 10.11.15+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.5+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.6.1+incompatible |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |