CVE-2026-46638
Fixed in a distro release EPSS <1%CVSS 6.0
Twig is a template language for PHP. Prior to 3.26.0, {% sandbox %}{% include %} can include a template that was previously loaded outside the sandbox without re-invoking checkSecurity(), allowing the cached template to use tags, filters, and functions that should have been denied by SecurityPolicy::checkSecurity(). This issue is fixed in version 3.26.0.
Products: twigphp Twig
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | twig/twig | 3.26.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | drupal-11.3 | 11.3.10-r0 |
| Debian 12 | php-twig | no fix |
| Debian 13 | php-twig | 3.27.0-0+deb13u1 |
| Debian 14 | php-twig | 3.26.0-1 |
| Ubuntu 25.10 | php-twig | no fix |
| Ubuntu 26.10 | php-twig | no fix |
| Ubuntu Pro 20.04 LTS | php-twig | no fix |
| Ubuntu Pro 22.04 LTS | php-twig | no fix |
| Ubuntu Pro 24.04 LTS | php-twig | no fix |
| Ubuntu Pro 26.04 LTS | php-twig | no fix |