Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-46587

Fixed upstream EPSS <1%CVSS 7.3

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Published 2026-07-06 · CVE record · OSV

Products: Apache Software Foundation Apache Camel

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.camel:camel-couchbase4.14.8
Mavenorg.apache.camel:camel-couchbase4.18.3
Mavenorg.apache.camel:camel-couchbase4.21.0