CVE-2026-4600
Fixed upstream EPSS <1%CVSS 7.4
Versions of the package jsrsasign before 11.1.1 are vulnerable to Improper Verification of Cryptographic Signature via the DSA domain-parameter validation in KJUR.crypto.DSA.setPublic (and the related DSA/X509 verification flow in src/dsa-2.0.js). An attacker can forge DSA signatures or X.509 certificates that X509.verifySignature() accepts by supplying malicious domain parameters such as g=1, y=1, and a fixed r=1, which make the verification equation true for any hash.
Products: Red Hat Migration Toolkit for Virtualization 2.1, Red Hat Migration Toolkit for Virtualization 2.9, Red Hat Quay 3.10, Red Hat Quay 3.12, Red Hat Quay 3.15, Red Hat Quay 3.16, Red Hat Quay 3.9
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | jsrsasign | 11.1.1 |