Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-44581

Fixed in a distro release EPSS <1%CVSS 4.7

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.

Published 2026-05-13 · CVE record · OSV

Products: vercel next.js

Fixed upstream

EcosystemPackageFixed in
npmnext15.5.16
npmnext16.2.5

Distro releases

ReleasePackageFixed in
Chainguardcadence-webno fix
Chainguardcommercial-chainloop-frontendno fix
Chainguardkeep-ui0.51.0-r7
Chainguardlangfuse-fips-3.152no fix