CVE-2026-44580
Fixed in a distro release EPSS <1%CVSS 6.1
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
Products: vercel next.js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | next | 15.5.16 |
| npm | next | 16.2.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | cadence-web | no fix |
| Chainguard | commercial-chainloop-frontend | no fix |
| Chainguard | keep-ui | 0.51.0-r7 |
| Chainguard | langfuse-fips-3.152 | no fix |