Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-44087

No fix known EPSS <1%CVSS 5.3

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Published 2026-06-19 · CVE record · OSV

Products: Apache Software Foundation Apache APISIX