CVE-2026-43868
Fixed in a distro release EPSS <1%CVSS 5.3
Memory Allocation with Excessive Size Value vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Products: Apache Software Foundation Apache Thrift, Red Hat Build of Apache Camel 3.33 for Quarkus 3.33.2.SP1, Red Hat OpenShift AI 2.25, Red Hat AI Inference Server, Red Hat build of Apache Camel 4 for Quarkus 3, Red Hat Data Grid 8, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat Fuse 7, Red Hat JBoss Enterprise Application Platform Expansion Pack, Red Hat OpenShift AI (RHOAI)
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| crates.io | thrift | 0.23.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | lakekeeper | 0.14.0-r0 |
| Chainguard | parseable | 3.2.0-r0 |
| Chainguard | vector | 0.58.0-r0 |
| Debian 12 | thrift | no fix |
| Debian 13 | thrift | no fix |
| Debian 14 | thrift | 0.23.0-3 |
| Ubuntu 20.04 LTS | thrift | no fix |
| Ubuntu 22.04 LTS | thrift | no fix |
| Ubuntu 24.04 LTS | thrift | no fix |
| Ubuntu 25.10 | thrift | no fix |
| Ubuntu 26.04 LTS | thrift | no fix |
| Ubuntu 26.10 | thrift | no fix |
| Wolfi | parseable | 3.2.0-r0 |
| Wolfi | vector | 0.58.0-r0 |