CVE-2026-42356
Fixed in a distro release EPSS <1%CVSS 3.7
Deployment of wrong handler vulnerability in Apache HTTP Server allows the target of some internal redirects from CGI programs to also be treated as CGI and executed. The target must already be in a directory enabled for CGI and have no other extension understood by mod_mime. This issue affects Apache HTTP Server: from 2.4.60 through 2.4.68.
Products: Apache Software Foundation Apache HTTP Server
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.21 | apache2 | 2.4.69-r0 |
| Alpine 3.22 | apache2 | 2.4.69-r0 |
| Alpine 3.23 | apache2 | 2.4.69-r0 |
| Alpine 3.24 | apache2 | 2.4.69-r0 |
| Debian 12 | apache2 | no fix |
| Debian 13 | apache2 | 2.4.69-1~deb13u1 |
| Debian 14 | apache2 | 2.4.69-1 |
| Red Hat hummingbird 1 | httpd | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | httpd-core | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | httpd-devel | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | httpd-filesystem | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | httpd-manual | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | httpd-tools | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | mod_ldap | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | mod_lua | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | mod_proxy_html | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | mod_session | 0:2.4.69-1.hum1 |
| Red Hat hummingbird 1 | mod_ssl | 0:2.4.69-1.hum1 |
| Ubuntu 22.04 LTS | apache2 | no fix |
| Ubuntu 24.04 LTS | apache2 | no fix |
| Ubuntu 26.04 LTS | apache2 | no fix |
| Ubuntu 26.10 | apache2 | no fix |
| Ubuntu Pro 14.04 LTS | apache2 | no fix |
| Ubuntu Pro 16.04 LTS | apache2 | no fix |
| Ubuntu Pro 18.04 LTS | apache2 | no fix |
| Ubuntu Pro 20.04 LTS | apache2 | no fix |