Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-42307

Fixed in a distro release EPSS <1%CVSS 4.4

Vim is an open source, command line text editor. Prior to version 9.2.0383, an OS command injection vulnerability exists in the netrw standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the sftp:// or file:// protocol handlers), an attacker can execute arbitrary shell commands with the privileges of the Vim process. This issue has been patched in version 9.2.0383.

Published 2026-05-08 · CVE record · OSV

Products: vim

Distro releases

ReleasePackageFixed in
Alpine 3.23vim9.2.0389-r0
Amazon Linux 2023vim-common2:9.2.597-1.amzn2023.0.1
Amazon Linux 2023vim-data2:9.2.597-1.amzn2023.0.1
Amazon Linux 2023vim-default-editor2:9.2.597-1.amzn2023.0.1
Amazon Linux 2023vim-enhanced2:9.2.597-1.amzn2023.0.1
Amazon Linux 2023vim-filesystem2:9.2.597-1.amzn2023.0.1
Amazon Linux 2023vim-minimal2:9.2.597-1.amzn2023.0.1
Amazon Linux 2023xxd2:9.2.597-1.amzn2023.0.1
Debian 12vimno fix
Debian 13vimno fix
Debian 14vim2:9.2.0428-1
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOSvim9.2.0530-150000.5.94.1
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSSvim9.2.0530-150000.5.94.1
SUSE Linux Enterprise Micro 5.3vim9.2.0530-150000.5.94.1
SUSE Linux Enterprise Micro 5.4vim9.2.0530-150000.5.94.1
SUSE Linux Enterprise Server 15 SP4-LTSSvim9.2.0530-150000.5.94.1
SUSE Linux Enterprise Server for SAP Applications 15 SP4vim9.2.0530-150000.5.94.1
SUSE Linux Micro Extras 6.2vim9.2.0530-160000.1.1
Ubuntu 22.04 LTSvim2:8.2.3995-1ubuntu2.30
Ubuntu 24.04 LTSvim2:9.1.0016-1ubuntu7.14
Ubuntu 25.10vim2:9.1.0967-1ubuntu6.5
Ubuntu 26.04 LTSvim2:9.1.2141-1ubuntu4.2
Ubuntu Pro 14.04 LTSvim2:7.4.052-1ubuntu3.1+esm26
Ubuntu Pro 16.04 LTSvim2:7.4.1689-3ubuntu1.5+esm32
Ubuntu Pro 18.04 LTSvim2:8.0.1453-1ubuntu1.13+esm17
Ubuntu Pro 20.04 LTSvim2:8.1.2269-1ubuntu5.32+esm5
openSUSE Tumbleweedvim9.2.0530-1.1