CVE-2026-42253
Fixed upstream EPSS 1%CVSS 6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. The MessageServlet in the ActiveMQ web console API copies every JMS message property into an HTTP response header without any validation. This can allow overwriting and injecting security headers by setting them on JMS messages that are returned by the servlet. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ Web: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue. The MessageServlet has now been deprecated and disabled by default.
Products: Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ Web
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.activemq:activemq-web | 5.19.7 |
| Maven | org.apache.activemq:activemq-web | 6.2.6 |
| Maven | org.apache.activemq:apache-activemq | 5.19.7 |
| Maven | org.apache.activemq:apache-activemq | 6.2.6 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-activemq-6.1 | no fix |
| Chainguard | apache-activemq-fips-6.1 | no fix |
| Debian 12 | activemq | no fix |
| Debian 13 | activemq | no fix |
| Ubuntu 24.04 LTS | activemq | no fix |
| Ubuntu 25.10 | activemq | no fix |
| Ubuntu 26.04 LTS | activemq | no fix |
| Ubuntu 26.10 | activemq | no fix |
| Ubuntu Pro 16.04 LTS | activemq | no fix |
| Ubuntu Pro 18.04 LTS | activemq | no fix |
| Ubuntu Pro 20.04 LTS | activemq | no fix |
| Ubuntu Pro 22.04 LTS | activemq | no fix |