CVE-2026-41990
Fixed in a distro release EPSS <1%CVSS 4.0
Libgcrypt before 1.12.2 mishandles Dilithium signing. Writes to a static array lack a bounds check but do not use attacker-controlled data.
Products: GnuPG libgcrypt
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 14 | libgcrypt20 | 1.12.2-1 |
| Red Hat hummingbird 1 | libgcrypt | 0:1.12.2-1.hum1 |
| Red Hat hummingbird 1 | libgcrypt-devel | 0:1.12.2-1.hum1 |
| SUSE Linux Enterprise Server 16.0 | libgcrypt | 1.12.1-160000.2.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | libgcrypt | 1.12.1-160000.2.1 |
| SUSE Linux Micro 6.2 | libgcrypt | 1.12.1-160000.2.1 |
| Ubuntu 22.04 LTS | libgcrypt20 | 1.9.4-3ubuntu3.2 |
| Ubuntu 24.04 LTS | libgcrypt20 | 1.10.3-2ubuntu0.1 |
| Ubuntu 25.10 | libgcrypt20 | 1.11.0-7ubuntu0.1 |
| Ubuntu 26.04 LTS | libgcrypt20 | 1.12.0-2ubuntu0.1 |
| Ubuntu Pro FIPS-updates 24.04 LTS | libgcrypt20 | 1.12.0-2ubuntu0.1~Fips1~rc11 |
| openSUSE Leap 16.0 | libgcrypt | 1.12.1-160000.2.1 |