CVE-2026-41850
Fixed in a distro release EPSS <1%CVSS 7.5
Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions are vulnerable to an Algorithmic Denial of Service (DoS). By providing a specially crafted expression, an attacker can trigger excessive resource consumption during evaluation, leading to application degradation or unavailability. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
Products: Spring Framework
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework:spring-expression | 7.0.8 |
| Maven | org.springframework:spring-expression | 6.2.19 |
| Maven | org.springframework:spring-expression | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-activemq-5.19 | no fix |
| Chainguard | apache-activemq-6.2 | 6.2.8-r2 |
| Chainguard | apache-activemq-fips-5.19 | no fix |
| Chainguard | apache-activemq-fips-6.2 | 6.2.8-r4 |
| Chainguard | apache-camel-karavan-devmode | 4.18.1-r8 |
| Chainguard | apache-nifi-registry | 2.10.0-r4 |
| Chainguard | apache-nifi-registry-toolkit | 2.10.0-r4 |
| Chainguard | camunda-8.9 | 8.9.13-r3 |
| Chainguard | camunda-zeebe-8.6 | 8.6.40-r0 |
| Chainguard | camunda-zeebe-8.9 | 8.9.13-r2 |
| Chainguard | data-prepper | no fix |
| Chainguard | geoserver-2.27 | no fix |
| Chainguard | geoserver-2.27-community | no fix |
| Chainguard | geoserver-2.28 | no fix |
| Chainguard | geoserver-2.28-community | no fix |
| Chainguard | jenkins-2.541 | 2.541.3-r10 |
| Chainguard | jenkins-2.541-openjdk-17 | 2.541.3-r10 |
| Chainguard | jenkins-2.541-openjdk-21 | 2.541.3-r10 |
| Chainguard | jenkins-2.541-openjdk-25 | 2.541.3-r10 |
| Chainguard | kafbat-ui | 1.5.0-r12 |
| Chainguard | kafbat-ui-fips | 1.5.0-r6 |
| Chainguard | kayenta-2025.2 | no fix |
| Chainguard | kayenta-fips-2025.2 | no fix |
| Chainguard | keycloak-config-cli | 6.5.1-r11 |
| Chainguard | keycloak-config-cli-iamguarded-compat | 6.5.1-r11 |
| Chainguard | ontop | no fix |
| Chainguard | ontop-fips | no fix |
| Chainguard | ranger | no fix |
| Chainguard | seata-server | no fix |
| Chainguard | zipkin | 3.6.1-r19 |
| Chainguard | zipkin-slim | 3.6.1-r19 |
| Debian 12 | libspring-java | no fix |
| Debian 13 | libspring-java | no fix |
| Debian 14 | libspring-java | no fix |
| Ubuntu 25.10 | libspring-java | no fix |
| Ubuntu 26.04 LTS | libspring-java | no fix |
| Ubuntu 26.10 | libspring-java | no fix |
| Ubuntu Pro 14.04 LTS | libspring-java | no fix |
| Ubuntu Pro 16.04 LTS | libspring-java | no fix |
| Ubuntu Pro 18.04 LTS | libspring-java | no fix |
| Ubuntu Pro 20.04 LTS | libspring-java | no fix |
| Ubuntu Pro 22.04 LTS | libspring-java | no fix |
| Ubuntu Pro 24.04 LTS | libspring-java | no fix |
| Wolfi | apache-nifi-registry | 2.10.0-r4 |
| Wolfi | apache-nifi-registry-toolkit | 2.10.0-r4 |
| Wolfi | keycloak-config-cli | 6.5.1-r11 |
| Wolfi | keycloak-config-cli-iamguarded-compat | 6.5.1-r11 |
| Wolfi | zipkin | 3.6.1-r19 |
| Wolfi | zipkin-slim | 3.6.1-r19 |