CVE-2026-41838
Fixed upstream EPSS <1%CVSS 4.8
IDs for WebSocket sessions in the spring-websocket module are not cryptographically unpredictable, which may be possible to exploit in combination with inadequate authorization rules. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.
Products: Spring Framework
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework:spring-websocket | 7.0.8 |
| Maven | org.springframework:spring-websocket | 6.2.19 |
| Maven | org.springframework:spring-websocket | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | libspring-java | no fix |
| Debian 13 | libspring-java | no fix |
| Debian 14 | libspring-java | no fix |
| Ubuntu 25.10 | libspring-java | no fix |
| Ubuntu 26.04 LTS | libspring-java | no fix |
| Ubuntu 26.10 | libspring-java | no fix |
| Ubuntu Pro 14.04 LTS | libspring-java | no fix |
| Ubuntu Pro 16.04 LTS | libspring-java | no fix |
| Ubuntu Pro 18.04 LTS | libspring-java | no fix |
| Ubuntu Pro 20.04 LTS | libspring-java | no fix |
| Ubuntu Pro 22.04 LTS | libspring-java | no fix |
| Ubuntu Pro 24.04 LTS | libspring-java | no fix |