Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-41608

Fixed in a distro release EPSS 1%CVSS 7.5

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Published 2026-07-27 · CVE record · OSV

Products: Apache Software Foundation Apache Thrift

Fixed upstream

EcosystemPackageFixed in
PyPIthrift0.24.0

Distro releases

ReleasePackageFixed in
Debian 12thriftno fix
Debian 13thriftno fix
Debian 14thriftno fix
Red Hat hummingbird 1perl-thrift0:0.24.0-0.1.hum1
Red Hat hummingbird 1python3-thrift0:0.24.0-0.1.hum1
Red Hat hummingbird 1thrift0:0.24.0-0.1.hum1
Red Hat hummingbird 1thrift-devel0:0.24.0-0.1.hum1
Red Hat hummingbird 1thrift-glib0:0.24.0-0.1.hum1
Red Hat hummingbird 1thrift-qt0:0.24.0-0.1.hum1
Ubuntu 20.04 LTSthriftno fix
Ubuntu 22.04 LTSthriftno fix
Ubuntu 24.04 LTSthriftno fix
Ubuntu 26.04 LTSthriftno fix
Ubuntu 26.10thriftno fix
openSUSE Tumbleweedthrift0.24.0-1.1