CVE-2026-41140
Fixed in a distro release EPSS <1%CVSS 0.6
Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.
Products: python-poetry poetry, Red Hat Ansible Automation Platform 2.6, Red Hat Ansible Automation Platform 2, Red Hat OpenShift AI (RHOAI), Red Hat OpenShift Container Platform 4, Red Hat Satellite 6
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | poetry | 2.3.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | request-1276 | no fix |
| Debian 12 | poetry | no fix |
| Debian 13 | poetry | 2.1.2+dfsg-1 |
| Debian 14 | poetry | 2.1.2+dfsg-1 |
| Ubuntu 22.04 LTS | poetry | no fix |
| Ubuntu 24.04 LTS | poetry | no fix |
| Ubuntu 25.10 | poetry | no fix |
| Ubuntu 26.04 LTS | poetry | no fix |
| Ubuntu 26.10 | poetry | no fix |