CVE-2026-41043
Fixed in a distro release EPSS <1%CVSS 6.5
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ Web
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.activemq:activemq-all | 5.19.6 |
| Maven | org.apache.activemq:activemq-all | 6.2.5 |
| Maven | org.apache.activemq:activemq-broker | 5.19.6 |
| Maven | org.apache.activemq:activemq-broker | 6.2.5 |
| Maven | org.apache.activemq:apache-activemq | 5.19.6 |
| Maven | org.apache.activemq:apache-activemq | 6.2.5 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-activemq-6.1 | no fix |
| Chainguard | apache-activemq-fips-6.1 | no fix |
| Chainguard | geoserver-2.27-community | 2.27.5-r9 |
| Chainguard | geoserver-2.28-community | 2.28.3-r7 |
| Debian:12 | activemq | no fix |
| Debian:13 | activemq | no fix |
| Ubuntu:24.04:LTS | activemq | no fix |
| Ubuntu:25.10 | activemq | no fix |
| Ubuntu:26.04:LTS | activemq | no fix |
| Ubuntu:26.10 | activemq | no fix |
| Ubuntu:Pro:16.04:LTS | activemq | no fix |
| Ubuntu:Pro:18.04:LTS | activemq | no fix |
| Ubuntu:Pro:20.04:LTS | activemq | no fix |
| Ubuntu:Pro:22.04:LTS | activemq | no fix |