CVE-2026-41008
Fixed upstream EPSS <1%CVSS 6.1
Spring Security Authorization Server's authorization endpoint performs insufficient validation of the request_uri parameter. An attacker can craft a malicious authorization request containing an invalid request_uri and an arbitrary, unvalidated redirect_uri, which can lead to an Open Redirect vulnerability. Affected versions: Spring Security 7.0.0 through 7.0.5. Spring Authorization Server 1.5.0 through 1.5.7.
Products: Spring Security, Spring Authorization Server
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework.security:spring-security-oauth2-authorization-server | 7.0.6 |
| Maven | org.springframework.security:spring-security-oauth2-authorization-server | 1.5.8 |