CVE-2026-41003
Fixed upstream EPSS <1%CVSS 7.6
An attacker able to influence values in RelyingPartyRegistration may be able to run arbitrary code on HTML forms generated by Spring Security filters. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.
Products: Spring Security
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework.security:spring-security-saml2-service-provider | 7.0.6 |
| Maven | org.springframework.security:spring-security-saml2-service-provider | 6.5.11 |
| Maven | org.springframework.security:spring-security-saml2-service-provider | no fix |