CVE-2026-40988
Fixed upstream EPSS <1%CVSS 7.5
An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.
Products: Spring Security
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.springframework.security:spring-security-saml2-service-provider | 7.0.6 |
| Maven | org.springframework.security:spring-security-saml2-service-provider | 6.5.11 |
| Maven | org.springframework.security:spring-security-saml2-service-provider | no fix |