Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-40976

Fixed in a distro release EPSS <1%CVSS 9.1

In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.

Published 2026-04-27 · CVE record · OSV

Products: Spring Boot, Red Hat AMQ Broker 7, Red Hat AMQ Clients, Red Hat build of Apache Camel for Spring Boot 4, Red Hat build of Apache Camel - HawtIO 4, Red Hat build of OptaPlanner 8, Red Hat Data Grid 8, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9, Red Hat Fuse 7, Red Hat JBoss Enterprise Application Platform 7, Red Hat JBoss Enterprise Application Platform 8, Red Hat JBoss Enterprise Application Platform Expansion Pack, Red Hat OpenShift Dev Spaces, Red Hat Process Automation 7, Red Hat Single Sign-On 7

Fixed upstream

EcosystemPackageFixed in
Mavenorg.springframework.boot:spring-boot4.0.6

Distro releases

ReleasePackageFixed in
Chainguardapache-nifi-registry2.9.0-r7
Chainguardapache-nifi-registry-toolkit2.9.0-r7
Chainguardcamunda-zeebe-8.98.9.5-r0
Wolfiapache-nifi-registry2.9.0-r7
Wolfiapache-nifi-registry-toolkit2.9.0-r7