Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-40261

Fixed in a distro release EPSS 2%CVSS 8.8

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::syncCodeBase() method, which appends the $sourceReference parameter to a shell command without proper escaping, and additionally in the Perforce::generateP4Command() method as in GHSA-wg36-wvj6-r67p / CVE-2026-40176, which interpolates user-supplied Perforce connection parameters (port, user, client) from the source url field without proper escaping. An attacker can inject arbitrary commands through crafted source reference or source url values containing shell metacharacters, even if Perforce is not installed. Unlike CVE-2026-40176, the source reference and url are provided as part of package metadata, meaning any compromised or malicious Composer repository can serve package metadata declaring perforce as a source type with malicious values. This vulnerability is exploitable when installing or updating dependencies from source, including the default behavior when installing dev-prefixed versions. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline). If developers are unable to immediately update, they can avoid installing dependencies from source by using --prefer-dist or the preferred-install: dist config setting, and only use trusted Composer repositories as a workaround.

Published 2026-04-15 · CVE record · OSV

Products: composer, Red Hat Hardened Images

Fixed upstream

EcosystemPackageFixed in
Packagistcomposer/composer2.9.6
Packagistcomposer/composer2.2.27

Distro releases

ReleasePackageFixed in
Chainguardcomposer2.9.7-r0
Debian:12composer2.5.5-1+deb12u4
Debian:13composer2.8.8-1+deb13u2
Debian:14composer2.9.7-1
Red Hat:hummingbird:1composer0:2.9.7-1.hum1
SUSE:Linux Enterprise Module for Web and Scripting 15 SP7php-composer22.6.4-150600.3.12.1
SUSE:Linux Enterprise Server 15 SP6-LTSSphp-composer22.6.4-150600.3.12.1
SUSE:Linux Enterprise Server 16.0php-composer22.8.9-160000.4.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP6php-composer22.6.4-150600.3.12.1
SUSE:Linux Enterprise Server for SAP applications 16.0php-composer22.8.9-160000.4.1
Ubuntu:25.10composerno fix
Ubuntu:26.04:LTScomposerno fix
Ubuntu:26.10composerno fix
Ubuntu:Pro:16.04:LTScomposerno fix
Ubuntu:Pro:18.04:LTScomposerno fix
Ubuntu:Pro:20.04:LTScomposerno fix
Ubuntu:Pro:22.04:LTScomposerno fix
Ubuntu:Pro:24.04:LTScomposerno fix
Wolficomposer2.9.7-r0
openSUSE:Leap 16.0php-composer22.8.9-160000.4.1
openSUSE:Tumbleweedphp-composer22.9.7-1.1