Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-40176

Fixed in a distro release EPSS 1%CVSS 7.8

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).

Published 2026-04-15 · CVE record · OSV

Products: composer, Red Hat Hardened Images

Fixed upstream

EcosystemPackageFixed in
Packagistcomposer/composer2.9.6
Packagistcomposer/composer2.2.27

Distro releases

ReleasePackageFixed in
Chainguardcomposer2.9.7-r0
Debian:12composer2.5.5-1+deb12u4
Debian:13composer2.8.8-1+deb13u2
Debian:14composer2.9.7-1
Red Hat:hummingbird:1composer0:2.9.7-1.hum1
SUSE:Linux Enterprise Module for Web and Scripting 15 SP7php-composer22.6.4-150600.3.12.1
SUSE:Linux Enterprise Server 15 SP6-LTSSphp-composer22.6.4-150600.3.12.1
SUSE:Linux Enterprise Server 16.0php-composer22.8.9-160000.4.1
SUSE:Linux Enterprise Server for SAP Applications 15 SP6php-composer22.6.4-150600.3.12.1
SUSE:Linux Enterprise Server for SAP applications 16.0php-composer22.8.9-160000.4.1
Ubuntu:25.10composerno fix
Ubuntu:26.04:LTScomposerno fix
Ubuntu:26.10composerno fix
Ubuntu:Pro:16.04:LTScomposerno fix
Ubuntu:Pro:18.04:LTScomposerno fix
Ubuntu:Pro:20.04:LTScomposerno fix
Ubuntu:Pro:22.04:LTScomposerno fix
Ubuntu:Pro:24.04:LTScomposerno fix
Wolficomposer2.9.7-r0
openSUSE:Leap 16.0php-composer22.8.9-160000.4.1
openSUSE:Tumbleweedphp-composer22.9.7-1.1