CVE-2026-40084
Fixed in a distro release EPSS <1%CVSS 6.5
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior are vulnerable to Path Traversal through the Report format_file Parameter, causing arbitrary file read. This vulnerability occurs in two stages. In the first stage (stored injection), lib/html_reports.php at line 283 stores $save['format_file'] = $post['format_file'] directly into the database without any validation. In the second stage (file read), lib/reports.php at line 667 concatenates CACTI_PATH_FORMATS . '/' . $format_file, and line 670 then calls file($format_file), reading arbitrary files from the filesystem. This issue has been fixed in version 1.2.31.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | cacti | no fix |
| Debian 13 | cacti | no fix |
| Debian 14 | cacti | 1.2.31+ds1-1 |
| Ubuntu 24.04 LTS | cacti | no fix |
| Ubuntu 25.10 | cacti | no fix |
| Ubuntu 26.04 LTS | cacti | no fix |
| Ubuntu 26.10 | cacti | no fix |
| Ubuntu Pro 14.04 LTS | cacti | no fix |
| Ubuntu Pro 16.04 LTS | cacti | no fix |
| Ubuntu Pro 18.04 LTS | cacti | no fix |
| Ubuntu Pro 20.04 LTS | cacti | no fix |
| Ubuntu Pro 22.04 LTS | cacti | no fix |