CVE-2026-40079
Fixed in a distro release EPSS 2%CVSS 8.6
Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior are vulnerable to Command Injection due to lack of sanitization in the escape_command() function. The escape_command() function at lib/rrd.php is a no-op: it returns $command unchanged. The command line built by rrdtool_function_graph() is passed through this function and then to shell_exec($full_commandline). The risk is in __rrd_execute() where text_format values from graph templates (which may contain host variable substitutions) reach shell_exec without adequate escaping. This issue has been addressed in version 1.2.31.
Products: cacti
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | cacti | no fix |
| Debian 13 | cacti | no fix |
| Debian 14 | cacti | 1.2.31+ds1-1 |
| Ubuntu 24.04 LTS | cacti | no fix |
| Ubuntu 25.10 | cacti | no fix |
| Ubuntu 26.04 LTS | cacti | no fix |
| Ubuntu 26.10 | cacti | no fix |
| Ubuntu Pro 14.04 LTS | cacti | no fix |
| Ubuntu Pro 16.04 LTS | cacti | no fix |
| Ubuntu Pro 18.04 LTS | cacti | no fix |
| Ubuntu Pro 20.04 LTS | cacti | no fix |
| Ubuntu Pro 22.04 LTS | cacti | no fix |