CVE-2026-40046
Fixed upstream EPSS <1%CVSS 7.5
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.
Products: Apache Software Foundation Apache ActiveMQ, Apache Software Foundation Apache ActiveMQ All, Apache Software Foundation Apache ActiveMQ MQTT
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Maven | org.apache.activemq:activemq-all | 6.2.4 |
| Maven | org.apache.activemq:activemq-mqtt | 6.2.4 |
| Maven | org.apache.activemq:apache-activemq | 6.2.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-activemq-6.1 | no fix |
| Chainguard | apache-activemq-fips-6.1 | no fix |
| Ubuntu 24.04 LTS | activemq | no fix |
| Ubuntu 25.10 | activemq | no fix |
| Ubuntu 26.04 LTS | activemq | no fix |
| Ubuntu 26.10 | activemq | no fix |
| Ubuntu Pro 16.04 LTS | activemq | no fix |
| Ubuntu Pro 18.04 LTS | activemq | no fix |
| Ubuntu Pro 20.04 LTS | activemq | no fix |
| Ubuntu Pro 22.04 LTS | activemq | no fix |