CVE-2026-3906
Fixed in a distro release EPSS <1%CVSS 4.3
WordPress core is vulnerable to unauthorized access in versions 6.9 through 6.9.1. The Notes feature (block-level collaboration annotations) was introduced in WordPress 6.9 to allow editorial comments directly on posts in the block editor. However, the REST API `create_item_permissions_check()` method in the comments controller did not verify that the authenticated user has `edit_post` permission on the target post when creating a note. This makes it possible for authenticated attackers with Subscriber-level access to create notes on any post, including posts authored by other users, private posts, and posts in any status.
Products: WordPress Foundation WordPress
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 14 | wordpress | 6.9.4+dfsg1-1 |
| Ubuntu 16.04 LTS | wordpress | no fix |
| Ubuntu 18.04 LTS | wordpress | no fix |
| Ubuntu 20.04 LTS | wordpress | no fix |
| Ubuntu 22.04 LTS | wordpress | no fix |
| Ubuntu 24.04 LTS | wordpress | no fix |
| Ubuntu 25.10 | wordpress | no fix |
| Ubuntu 26.04 LTS | wordpress | no fix |
| Ubuntu 26.10 | wordpress | no fix |