CVE-2026-3902
Fixed in a distro release EPSS <1%CVSS 7.5
An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30. `ASGIRequest` allows a remote attacker to spoof headers by exploiting an ambiguous mapping of two header variants (with hyphens or with underscores) to a single version with underscores. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Tarek Nakkouch for reporting this issue.
Products: djangoproject django
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | django | 6.0.4 |
| PyPI | django | 5.2.13 |
| PyPI | django | 4.2.30 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | authentik-2025.12 | 2025.12.4-r3 |
| Chainguard | authentik-2026.2 | 2026.2.1-r3 |
| Chainguard | authentik-fips-2025.12 | 2025.12.4-r3 |
| Chainguard | authentik-fips-2026.2 | 2026.2.1-r3 |
| Chainguard | awx | 24.6.1-r34 |
| Chainguard | label-studio | 1.23.0-r3 |
| Debian 12 | python-django | no fix |
| Debian 13 | python-django | no fix |
| Debian 14 | python-django | 3:4.2.30-1 |
| Ubuntu 22.04 LTS | python-django | 2:3.2.12-2ubuntu1.26 |
| Ubuntu 24.04 LTS | python-django | 3:4.2.11-1ubuntu1.15 |
| Ubuntu 25.10 | python-django | 3:5.2.4-1ubuntu2.4 |
| Ubuntu Pro 18.04 LTS | python-django | 1:1.11.11-1ubuntu1.21+esm15 |
| Ubuntu Pro 20.04 LTS | python-django | 2:2.2.12-1ubuntu0.29+esm8 |
| openSUSE Leap 16.0 | python-Django | 5.2.4-bp160.7.1 |
| openSUSE Tumbleweed | python-Django | 5.2.13-1.1 |
| openSUSE Tumbleweed | python-Django4 | 4.2.30-1.1 |
| openSUSE Tumbleweed | python-Django5 | 5.2.16-1.1 |
| openSUSE Tumbleweed | python-Django6 | 6.0.4-1.1 |