CVE-2026-3713
Fixed in a distro release EPSS <1%CVSS 5.3
A flaw has been found in pnggroup libpng up to 1.6.55. Affected by this vulnerability is the function do_pnm2png of the file contrib/pngminus/pnm2png.c of the component pnm2png. This manipulation of the argument width/height causes heap-based buffer overflow. The attack is restricted to local execution. The exploit has been published and may be used. The project was informed of the problem early through an issue report but has not responded yet.
Products: pnggroup libpng
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | libpng1.6 | no fix |
| Debian 13 | libpng1.6 | no fix |
| Debian 14 | libpng1.6 | no fix |
| Red Hat hummingbird 1 | libpng | 0:1.6.56-1.hum1 |
| Red Hat hummingbird 1 | libpng-devel | 0:1.6.56-1.hum1 |
| Red Hat hummingbird 1 | libpng-static | 0:1.6.56-1.hum1 |
| Red Hat hummingbird 1 | libpng-tools | 0:1.6.56-1.hum1 |
| Ubuntu Pro 14.04 LTS | libpng | no fix |