CVE-2026-3637
Fixed in a distro release EPSS <1%CVSS 4.3
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to check the create_post channel permission during post edit operations which allows an authenticated attacker with revoked posting privileges to modify their existing posts via direct API requests to the post update and patch endpoints.. Mattermost Advisory ID: MMSA-2026-00627
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 5.3.2-0.20260316171743-090408f09f53 |
| Go | github.com/mattermost/mattermost-server | 10.11.14+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.2+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 10.11.14 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.4.4 |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260316171743-090408f09f53 |
| Go | github.com/mattermost/mattermost/server/v8 | 11.5.2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |