CVE-2026-3590
Fixed in a distro release EPSS <1%CVSS 6.5
Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to enforce atomic single-use consumption of guest magic link tokens, which allows an attacker with access to a valid magic link to establish multiple independent authenticated sessions via concurrent requests.. Mattermost Advisory ID: MMSA-2026-00624
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 10.11.13 |
| Go | github.com/mattermost/mattermost-server | 11.5.0 |
| Go | github.com/mattermost/mattermost-server | 11.4.3 |
| Go | github.com/mattermost/mattermost-server | 11.3.3 |
| Go | github.com/mattermost/mattermost-server | 10.11.13+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.3.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.3+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.0+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20250723052842-4cb8d8940332 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |