CVE-2026-3520
Fixed in a distro release EPSS <1%CVSS 8.7
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.
Products: expressjs multer, Red Hat Developer Hub 1.8, Red Hat Developer Hub 1.9, Red Hat Self-service automation portal 2
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | multer | 2.1.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | librechat | 0.8.2-r7 |
| Chainguard | redisinsight | 3.2.0-r1 |