CVE-2026-34756
Fixed in a distro release EPSS <1%CVSS 6.5
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.
Products: vllm-project vllm, Red Hat AI Inference Server 3.2, Red Hat AI Inference Server 3.4, Red Hat Enterprise Linux AI 3.4, Red Hat AI Inference Server, Red Hat OpenShift AI (RHOAI)
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.19.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | py3.10-vllm-cuda-12.4 | 0.18.1-r2 |
| Chainguard | py3.10-vllm-cuda-12.4 | 0.18.1-r1 |
| Chainguard | py3.12-vllm-cuda-12.4 | 0.18.1-r1 |
| Chainguard | py3.12-vllm-cuda-12.4 | 0.18.1-r2 |
| Chainguard | tritonserver-backend-vllm-cuda-12.9 | no fix |
| Chainguard | tritonserver-backend-vllm-cuda-13.0 | 25.11-r7 |
| Chainguard | vllm-openai-cuda-12.9 | 0.19.0-r0 |