CVE-2026-3433
Fixed in a distro release EPSS <1%CVSS 4.3
Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to restrict role_updated websocket event broadcasts to members of the affected team or channel which allows an authenticated attacker with guest-level access to observe permission scheme change notifications for private teams they are not a member of via the websocket connection.. Mattermost Advisory ID: MMSA-2026-00616
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.6.1 |
| Go | github.com/mattermost/mattermost-server | 11.5.5 |
| Go | github.com/mattermost/mattermost-server | 10.11.17 |
| Go | github.com/mattermost/mattermost-server | 10.11.17+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.5+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.6.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260504071740-9408b98025d7 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE:Linux Enterprise Server 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| SUSE:Linux Enterprise Server for SAP applications 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |