CVE-2026-33865
Fixed in a distro release EPSS <1%CVSS 5.1
MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface. An authenticated attacker can upload a malicious MLmodel file containing a payload that executes when another user views the artifact in the UI. This allows actions such as session hijacking or performing operations on behalf of the victim. This issue affects MLflow version through 3.10.1
Products: mlflow
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | mlflow | 3.11.1 |
| PyPI | mlflow | 3.11.0rc0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | mlflow | 3.16.0-r0 |
| Chainguard | mlflow | 3.11.1-r0 |
| Chainguard | mlflow-fips | 3.11.1-r0 |
| Wolfi | mlflow | 3.16.0-r0 |
| Wolfi | mlflow | 3.11.1-r0 |