CVE-2026-33337
Fixed in a distro release EPSS <1%CVSS 7.5
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server, potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
Products: firebirdsql firebird
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | firebird3.0 | no fix |
| Debian 13 | firebird3.0 | no fix |
| Debian 13 | firebird4.0 | no fix |
| Debian 14 | firebird3.0 | 3.0.14.ds7-1 |
| Debian 14 | firebird4.0 | 4.0.7.3271.ds6-1 |
| Ubuntu 18.04 LTS | firebird3.0 | no fix |
| Ubuntu 20.04 LTS | firebird3.0 | no fix |
| Ubuntu 22.04 LTS | firebird3.0 | no fix |
| Ubuntu 24.04 LTS | firebird3.0 | no fix |
| Ubuntu 25.10 | firebird3.0 | no fix |
| Ubuntu 25.10 | firebird4.0 | no fix |
| Ubuntu 26.04 LTS | firebird3.0 | no fix |
| Ubuntu 26.04 LTS | firebird4.0 | no fix |
| Ubuntu 26.10 | firebird3.0 | no fix |
| Ubuntu 26.10 | firebird4.0 | no fix |