Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-32829

Fixed in a distro release EPSS <1%CVSS 8.2

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

Published 2026-03-20 · CVE record · OSV

Products: PSeitz lz4_flex, Logging Subsystem for Red Hat OpenShift 6.2, Logging Subsystem for Red Hat OpenShift 6.4, Logging Subsystem for Red Hat OpenShift 6.5, Red Hat OpenShift AI 3.3, Red Hat OpenShift Lightspeed, Red Hat Ansible Automation Platform 2, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 9, Red Hat OpenShift AI (RHOAI)

Fixed upstream

EcosystemPackageFixed in
crates.iolz4_flex0.11.6
crates.iolz4_flex0.12.1

Distro releases

ReleasePackageFixed in
Chainguardgarage-11.3.1-r3
Chainguardgarage-22.2.0-r2
Chainguardgarage-2.22.2.0-r3
Chainguardparseable2.6.1-r1
Chainguardpy3.10-hf-xet1.4.2-r1
Chainguardpy3.11-hf-xet1.4.2-r1
Chainguardpy3.13-hf-xet1.4.2-r1
Chainguardqdrant1.17.0-r5
Chainguardvector0.54.0-r3
Debian 13rust-lz4-flexno fix
Debian 14rust-lz4-flex0.13.0-1
Ubuntu 24.04 LTSrust-lz4-flexno fix
Ubuntu 25.10rust-lz4-flexno fix
Ubuntu 26.04 LTSrust-lz4-flexno fix
Ubuntu 26.10rust-lz4-flexno fix
Wolfiparseable2.6.1-r1
Wolfipy3.10-hf-xet1.4.2-r1
Wolfipy3.11-hf-xet1.4.2-r1
Wolfipy3.13-hf-xet1.4.2-r1
Wolfiqdrant1.17.0-r5
Wolfivector0.54.0-r3