Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-32773

Fixed upstream EPSS <1%CVSS 6.1

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Published 2026-09-02 · CVE record · OSV

Products: Apache Software Foundation Apache Spark

Fixed upstream

EcosystemPackageFixed in
Mavenorg.apache.spark:spark-core_2.123.5.8
Mavenorg.apache.spark:spark-core_2.133.5.8
PyPIpyspark3.5.8